Jump to content
IGNORED

Welche Elektronikkommunikation wird bei Kawasaki verbaut? CAN Bus?


tralf
 Share

Recommended Posts

Guest CBR Umsteiger

Hallo,

 

ich bin auch an dem Thema sehr interessiert.

Habe mir eine Gopro geleistet und habe einige Montagepunkte an welchen die Armaturen nicht im Bild sind.

Ich würde nun gern die Daten (Drehzahl, Geschwindigkeit, vielleicht Gasgriffstellung, usw.) mit loggen und mittels SW (Racechrono2AVI) ins Video bringen.

 

Die notwendige Elektronik Bastelei stellt für mich kein Problem dar. Ich benötige nur das Protokoll der Schnittstelle. 

Edited by CBR Umsteiger
Link to comment
Share on other sites

  • 1 month later...

Ich benötige nur das Protokoll der Schnittstelle. 

 

Im Racechrono2AVI-Installationsverzeichnis ist ein Ordner csv, in dem Beispieldateien sind, aus denen eigentlich recht gut das Protokoll ersichtlich ist. Oder welches Protokoll meinst du?

 

Edit: ich glaub die Antwort hätte ich mir sparen können, wenn ich vorher darauf geachtet hätte wann er das letzte Mal online war ^^

Edited by mistake
Link to comment
Share on other sites

  • 9 months later...

Das sieht ja mal richtig gut aus!

 

Hast du den Arduino Sketch schon? 

Edited by philro
Link to comment
Share on other sites

Hast du den Arduino Sketch schon? 

Nein, ich benutze einen ELM327-Adapter, und mache bisher alle Abfragen händisch (ohne Erfolg).

Link to comment
Share on other sites

Ich denke das es am Timing liegt warum das händisch nicht funktioniert. In dem von dir oben verlinkten Forum ist die Rede von einer Initialisierungsfunktion. 

(K-Line Low 25ms, K-Line High 25ms)

 

Ich versuche mal die Infos für den Arduino Betrieb zusammen zu fassen, könnte das jemand bestätigen:

 

Diagnose Stecker unter der Sozius Sitzbank

- Rot = +12V

- Schwarz = GND

- Grün = K-Line

 

K-Line über Level Konverter auf den Arduino

Link to comment
Share on other sites

Timingprobleme halte ich für unwahrscheinlich, weil das alles im ELM abgewickelt wird und ich nur das Kommando dafür gebe. Ich vermute eher, dass es der ECU nicht ausreicht, nur mit 12V, Zündung und Masse verbunden zu sein. Vielleicht müssen noch mehr Pins korrekt belegt sein. Ich habe es jetzt an 2 unterschiedlichen ECU getestet, in beiden Fällen kommt keine Antwort. Da es mit einer BMS-K aber funktioniert, schliesse ich einen Fehler auf meiner Seite aus. Vermutlich ist es das einfachste, mit dem Bike-Sim zu beginnen, den brauche ich ja sowieso.

 

Nach Schaltplan sind die Farben R/Y für K-Line, BK/Y für Masse und W/Y für Zündung (Kl. 15)

Link to comment
Share on other sites

Das mit den Timingproblemen war nicht auf die Kommunikation an sich bezogen sondern auf den Initialisierungs Prozess. So wie ich den Thread im ecuhacking Board verstanden habe sendet das ECU erst Daten nach diesem Initialisierungs Prozess

 

KLine Low 25ms

Kline High 25ms

Startframe mit: "81 11 F1 81 04"

Link to comment
Share on other sites

Hi,

 

hast du auch die Belegung des Diagnose Steckers? 

 

BK/Y = GND

BR/W= +12V

Bl = ?

BK/Cyan = ?

Edited by philro
Link to comment
Share on other sites

Ah OK, dann wurden wohl die Kabelfarben geändert. Meine Kabelfarben sind von einer Z1000 BJ 2013. Die gleichen Farben habe ich in einer 2011er ER6-N gefunden. 

Hat hier jemand die Belegung?

Wenn ich mich recht erinnere führt die K-Line ca 11 Volt wenn nichts angeschlossen ist, ist das korrekt?

Link to comment
Share on other sites

Bike-Sim ansatzweise fertig, weit genug, dass die Kommunikation läuft, mit der ECU ausgebaut auf dem Schreibtisch. Wie vermutet: es muss der immobilizer amplifier angeschlossen und ein passender Schlüssel eingesteckt sein, sonst geht es nicht.  Im Request müssen physikalische Adressen und  - ausser bei der Initialisierung - 4-Byte-Header geschickt werden. Der Umfang der unterstützten SID scheint sehr klein zu sein, noch nicht mal die Serien-Nummer der ECU oder Trouble Codes konnte ich abfragen, das gibt eine Fehlermeldung von der ECU.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.